Cities XL 2011 Language

Moderator: Focus Team

punkmanmatthew
Posts: 8
Joined: 29 October 2011, 15:48

Cities XL 2011 Language

Postby punkmanmatthew » 29 October 2011, 17:37

I just purchased Cities XL 2011 and I live in China right now. The game is all in Chinese and I don't think there is a language choosing option when I install the game. When I install the game it's in some really strange language that I cannot read. When I play the game it's all in Chinese. Does anyone know if there is a way to make the game English. I've looked online a lot and cannot find anything that works or really find anything. I tried some kind of regedit trick to make it English but that did not work. If anyone knows what to do I will kiss you. Actually only if you are a very pretty girl.

Thanks,
Matt

ThierryFocus
Moderator
Posts: 130
Joined: 03 September 2010, 14:59

Re: Cities XL 2011 Language

Postby ThierryFocus » 31 October 2011, 19:10

punkmanmatthew wrote:I just purchased Cities XL 2011 and I live in China right now. The game is all in Chinese and I don't think there is a language choosing option when I install the game. When I install the game it's in some really strange language that I cannot read. When I play the game it's all in Chinese. Does anyone know if there is a way to make the game English. I've looked online a lot and cannot find anything that works or really find anything. I tried some kind of regedit trick to make it English but that did not work. If anyone knows what to do I will kiss you. Actually only if you are a very pretty girl.

Thanks,
Matt


See properties on your desktop shorcut. In the shorcut tab, you should have a field "target".

Maybe you have this

"C:\Program Files\Focus Home Interactive\Cities XL 2011\CitiesXL_2012.exe" LOCALIZATION/LANGUAGE=tw

Replace the tw at the end by en to play in English.

punkmanmatthew
Posts: 8
Joined: 29 October 2011, 15:48

Re: Cities XL 2011 Language

Postby punkmanmatthew » 01 November 2011, 13:14

I'm sorry my data folder does not have any Localization folder in it. Is there a way I can get this folder and get the en file?

ThierryFocus
Moderator
Posts: 130
Joined: 03 September 2010, 14:59

Re: Cities XL 2011 Language

Postby ThierryFocus » 03 November 2011, 00:36

In this case, you have to change the file globalsettings.cfg then please refer to this topic:

viewtopic.php?p=51842#p51842

punkmanmatthew
Posts: 8
Joined: 29 October 2011, 15:48

Re: Cities XL 2011 Language

Postby punkmanmatthew » 03 November 2011, 15:36

This is what my config settings are. I believe they are correct but everything is still in Chinese.

Code: Select all

<?xml version="1.0" encoding="Windows-1252"?>

<StartingState>SPACEVIEW</StartingState>
<StartingScreen>S_INTROVIDEO</StartingScreen>


<Localization_CSMS>
  <Language>en</Language>
  <AsianFonts>1</AsianFonts>
  <FontHead>Comic Sans MS</FontHead>
  <FontBody>Comic Sans MS</FontBody>
  <FontAux>Comic Sans MS</FontAux>
  <FontDecor>Comic Sans MS</FontDecor>
  <FontLib>gfxfontlib_en.gfx</FontLib>
</Localization_CSMS>

<Localization>
  <Language>en</Language>
  <AsianFonts>1</AsianFonts>
  <FontHead>Arial</FontHead>
  <FontBody>Arial</FontBody>
  <FontAux>Arial</FontAux>
  <FontDecor>Arial</FontDecor>
  <FontLib>gfxfontlib_en.gfx</FontLib>
</Localization>

<Localization_JAP>
  <Language>jp</Language>
  <AsianFonts>1</AsianFonts>
  <FontHead>Arial Unicode MS</FontHead>
  <FontBody>Arial Unicode MS</FontBody>
  <FontAux>Arial Unicode MS</FontAux>
  <FontDecor>Arial Unicode MS</FontDecor>
  <FontLib>gfxfontlib_en.gfx</FontLib>
</Localization_JAP>

User avatar
nicko2u
Posts: 392
Joined: 17 August 2011, 09:35

Re: Cities XL 2011 Language

Postby nicko2u » 03 November 2011, 15:50

I think you need to add the Unicode MS data info otherwise the code won't recognize the characters.

Code: Select all

<Localization_CSMS>
  <Language>en</Language>
  <AsianFonts>1</AsianFonts>
  <FontHead>Comic Sans MS</FontHead>
  <FontBody>Comic Sans MS</FontBody>
  <FontAux>Comic Sans MS</FontAux>
  <FontDecor>Comic Sans MS</FontDecor>
  <FontLib>gfxfontlib_en.gfx</FontLib>
</Localization_CSMS>

<Localization>
  <Language>en</Language>
  <AsianFonts>1</AsianFonts>
  <FontHead>Arial Unicode MS</FontHead>
  <FontBody>Arial Unicode MS</FontBody>
  <FontAux>Arial Unicode MS</FontAux>
  <FontDecor>Arial Unicode MS</FontDecor>
  <FontLib>gfxfontlib_en.gfx</FontLib>
</Localization>

<Localization_JAP>
  <Language>jp</Language>
  <AsianFonts>1</AsianFonts>
  <FontHead>Arial Unicode MS</FontHead>
  <FontBody>Arial Unicode MS</FontBody>
  <FontAux>Arial Unicode MS</FontAux>
  <FontDecor>Arial Unicode MS</FontDecor>
  <FontLib>gfxfontlib_en.gfx</FontLib>
</Localization_JAP>


punkmanmatthew
Posts: 8
Joined: 29 October 2011, 15:48

Re: Cities XL 2011 Language

Postby punkmanmatthew » 03 November 2011, 16:01

So I change my config file to:

I had the same problem before. I am now OK. You may try this solution.

1. Edit the GlobalSetting.cfg file, if your file has different tags about Localization, just keep the following tag and delete others, e.g. <Localization_CSMS> and <Localization_JAP>.
<Localization>
<Language>en</Language>
<AsianFonts>1</AsianFonts>
<FontHead>Arial Unicode MS</FontHead>
<FontBody>Arial Unicode MS</FontBody>
<FontAux>Arial Unicode MS</FontAux>
<FontDecor>Arial Unicode MS</FontDecor>
<FontLib>gfxfontlib_en.gfx</FontLib>
</Localization>


Just like the other post say. But all I get are the boxes for letters. There is no English just boxes and I tried every way the other tutorial gave me
says to try but nothing works. It's either just boxes or Chinese.

User avatar
nicko2u
Posts: 392
Joined: 17 August 2011, 09:35

Re: Cities XL 2011 Language

Postby nicko2u » 03 November 2011, 16:12

So what are you saying your problem is fixed or not adding the Unicode Ms settings?
Basically just copy and paste all the code i added over yours.

punkmanmatthew
Posts: 8
Joined: 29 October 2011, 15:48

Re: Cities XL 2011 Language

Postby punkmanmatthew » 03 November 2011, 16:21

Also when I completely take out my config file the language just goes back to Chinese.

One thing I do notice is that at the very beginning it says "press escape to skip" talking about the
intro to the game. That is in English. But when the game starts it's all in Chinese.

User avatar
nicko2u
Posts: 392
Joined: 17 August 2011, 09:35

Re: Cities XL 2011 Language

Postby nicko2u » 03 November 2011, 16:45

Your not answering my questions so just keep talking in circles :O


Return to “Technical Forum”

Who is online

Users browsing this forum: No registered users and 1 guest

cron